vue项目,安装依赖时提示:cb() never called的解决方法:

  1. 以管理员身份执行:npm install -g windows-build-tools

或者:

  1. 安装python3.x(node-gyp 依赖python3.x) 和 python2.7 然后执行:npm config set python python2.7
  2. 安装 Visual Studio Build Tools 或  Visual Studio 2017 Community,然后执行:npm config set msvs_version 2017